const regex = /^(([\d]{9}[13579]\d [a-z]+ski)|([\d]{9}[02468]\d [a-z]+ska))$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([\\d]{9}[13579]\\d [a-z]+ski)|([\\d]{9}[02468]\\d [a-z]+ska))$', 'g')
const str = `96112103648 kowalska
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}