const regex = /<p>([^:]+)\s*:\s*([\d.]+\s+\w+)<\/p>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<p>([^:]+)\\s*:\\s*([\\d.]+\\s+\\w+)<\\\/p>', 'g')
const str = `<p>Packet size: 20 cm</p><p>Weight: 1.2 kg</p><p>Allows you to collect your hair easily.</p><p><br />Holds your hair, does not come out.</p><p>No more fussing with rubber buckles.</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}