$re = '/^.+(.log|.txt)(.\d)?$/m';
$str = 'test.jpg
abc.123
output.log
output.log.1
output.log.2.5.txt
output.log.2.tar.gz
output.1.txt
output.txt
index.html
file.zip';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);