$re = '/a(b|c)/m';
$str = 'a
ab
ac
abc
acb
ad
ae';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);