#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{8})\s*(\d{10})\s*([\d/]+)\s*([\d\.]+)\s*([\d\.]+)\s*([\d\.]+)"
Local $sString = "" & @CRLF & _
" " & @CRLF & _
"We have effected a fund transfer to a/c No 00070110000017 with HDFC BANK for Rs" & @CRLF & _
"19,44,671.20(Rupees Ninteen Lakh Forty Four Thousand Six Hundred Seventy One and Paise" & @CRLF & _
"Twenty Only) against the below mentioned payment Details." & @CRLF & _
"________________________________________________________________________________ " & @CRLF & _
"Invoice Number Document Number Document date Invoice Amount " & @CRLF & _
"Deductions Net Amount " & @CRLF & _
"________________________________________________________________________________ " & @CRLF & _
" 108027883 5001211394 28/12/2020 486167.80 " & @CRLF & _
" 0.00 486167.80 " & @CRLF & _
" 108027884 5001211396 28/12/2020 486167.80 " & @CRLF & _
" 0.00 486167.80 " & @CRLF & _
" 108027886 5001211401 28/12/2020 486167.80 " & @CRLF & _
" 0.00 486167.80 " & @CRLF & _
" 108027885 5001211408 28/12/2020 486167.80 " & @CRLF & _
" 0.00 486167.80 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")