// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{8})\s*(\d{10})\s*([\d/]+)\s*([\d\.]+)\s*([\d\.]+)\s*([\d\.]+)").unwrap();
let string = "
We have effected a fund transfer to a/c No 00070110000017 with HDFC BANK for Rs
19,44,671.20(Rupees Ninteen Lakh Forty Four Thousand Six Hundred Seventy One and Paise
Twenty Only) against the below mentioned payment Details.
________________________________________________________________________________
Invoice Number Document Number Document date Invoice Amount
Deductions Net Amount
________________________________________________________________________________
108027883 5001211394 28/12/2020 486167.80
0.00 486167.80
108027884 5001211396 28/12/2020 486167.80
0.00 486167.80
108027886 5001211401 28/12/2020 486167.80
0.00 486167.80
108027885 5001211408 28/12/2020 486167.80
0.00 486167.80 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}