#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^\*\*Header2\*\*.*[\n\r]" & @CRLF & _
"(?P<content>[\s\S]+?)" & @CRLF & _
"(?=^\*\*)"
Local $sString = "**Header1** " & @CRLF & _
"thing1 " & @CRLF & _
"thing2 " & @CRLF & _
"thing3 " & @CRLF & _
"thing4 " & @CRLF & _
"" & @CRLF & _
"**Header2** " & @CRLF & _
"dsfgs " & @CRLF & _
"sdgsg " & @CRLF & _
"" & @CRLF & _
"empty line" & @CRLF & _
"rrrrrr " & @CRLF & _
"" & @CRLF & _
"**Hello Dolly** " & @CRLF & _
"abider " & @CRLF & _
"abcder " & @CRLF & _
"ffffff" & @CRLF & _
"" & @CRLF & _
"etc."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")