import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\*\\*Header2\\*\\*.*[\\n\\r]\n"
+ "(?P<content>[\\s\\S]+?)\n"
+ "(?=^\\*\\*)";
final String string = "**Header1** \n"
+ "thing1 \n"
+ "thing2 \n"
+ "thing3 \n"
+ "thing4 \n\n"
+ "**Header2** \n"
+ "dsfgs \n"
+ "sdgsg \n\n"
+ "empty line\n"
+ "rrrrrr \n\n"
+ "**Hello Dolly** \n"
+ "abider \n"
+ "abcder \n"
+ "ffffff\n\n"
+ "etc.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}