import Foundation
let pattern = #"Wert:[ ]+<\/td>\n[ ]+<td align="left"><b>(.*)<\/b><\/td>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<td align="right">Account: </td>
<td align="left"><b>1234</b></td>
<td align="right">Nummer: </td>
<td align="left"><b></b></td>
</tr>
<tr class="style2" bgcolor="#0000BB">
<td align="right">Wert: </td>
<td align="left"><b>10,36</b></td>
<td align="right">XY:</td>
<td align="left"><b></b></td>
<td align="right">ABC: </td>
<td align="left"><b></b></td>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)