using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+) (\w+)(?: \+| -|$)";
string input = @"12 CO2 + 6 H2O -> 2 C6H12O6 + 12 O2";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}