// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d+) (\w+)(?: \+| -|$)").unwrap();
let string = "12 CO2 + 6 H2O -> 2 C6H12O6 + 12 O2";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}