package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<name>\b\w+\b)\s*=\s*(?<value>"[^"]*"|'[^']*'+)`)
var str = `id='1019' name='Beer' color='#e7c705'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}