re = /^(?=\S{5,100}$)(?!\S*\d{9})[A-Za-z0-9][A-Za-z0-9$\\._-]*@[A-Za-z0-9$\\._-]+\.[A-Za-z0-9]+$/m
str = 'test@test.com
test@test.co.uk
test123456789@test.com
test@test
$test@test.com
test@test@test.com
test@test().com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end