re = /^([0-9]|1[0-2]):[0-5][0-9][ ]?([AP]M|[ap]m)/m
str = '1:29 am
12:56PM
9:12 PM
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end