import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\[Fichier:(?:\\[\\[.*?\\]\\]|[^]])*\\]\\]";
final String string = "=== Langues ===\n"
+ "{{Article détaillé|Langues en Afrique du Sud}}\n"
+ "[[Fichier:South Africa dominant language map.svg|thumb|300px| Répartition \n"
+ "des langues officielles dominantes par région :\n"
+ "{{clear}}\n"
+ "{{legend|#80b1d3|[[Zoulou]]}}\n"
+ "{{legend|#8dd3c7|[[Afrikaans]]}}\n"
+ "{{legend|#fb8072|[[Xhosa (langue)|Xhosa]]}}\n"
+ "{{legend|#ffffb3|[[Anglais]]}}\n"
+ "{{legend|#fccde5|[[Tswana|Setswana]]}}\n"
+ "{{legend|#bebada|[[Ndébélés|Ndebele]]}}\n"
+ "{{legend|#fdb462|[[Sotho du Nord]]}}\n"
+ "{{legend|#b3de69|[[Sotho du Sud]]}}\n"
+ "{{legend|#bc80bd|[[Swati]]}}\n"
+ "{{legend|#ccebc5|[[Venda (langue)|Tshivenda]]}}\n"
+ "{{legend|#ffed6f|[[Tsonga (langue)|Xitsonga]]}}\n"
+ "{{legend|#d0d0d0|Pas de langage dominant}}]]\n"
+ "Il n'y a pas de langue maternelle majoritairement dominante en Afrique du Sud. Depuis [[1994]], [[Langues en Afrique du Sud|onze langues officielles]] (anglais, afrikaans, zoulou, xhosa, zwazi, ndebele, sesotho, sepedi, setswana, xitsonga, tshivenda<ref>[http://www.lafriquedusud.com/ethnies.htm lafriquedusud.com]</ref>) sont reconnues par la [[Constitution de l'Afrique du Sud|Constitution sud-africaine]]<ref>{{Ouvrage|langue=fr|auteur1=François- Xavier Fauvelle-Aymar|titre=Histoire \n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}