import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z].*\\R\\K[0-9](?=\\R0$)";
final String string = "ABC\n"
+ "5\n"
+ "0\n"
+ "gdfgdfg\n"
+ "-----------\n"
+ "GHN\n"
+ "0\n"
+ "ffffffff\n"
+ "fffff\n"
+ "ffff\n"
+ "trte\n"
+ "-------------\n"
+ "H\n"
+ "1\n"
+ "0\n"
+ "----------------";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}