re = /(([0-2]\d|30)\/(0[4-9]|1[012])|(31\/(0[578]|10|12)))\/1999/m
str = '01/03/1999 too early
30/03/1999 too early
01/04/1999
31/04/1999 invalid date (month-specific)
35/04/1999 invalid date
30/05/1999
31/05/1999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end