package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^a-z0-9\n])`)
var str = `line_1
line_2`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}