#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\w+)(?:(?:=|:)\w+)?$"
Local $sString = "https://dev.testapi.com/api/v1/properties?id:xyz&surname:kronenberg&active=true" & @CRLF & _
"https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&property_type:true" & @CRLF & _
"https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&active:true" & @CRLF & _
"https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&user_id:true" & @CRLF & _
"dev.testapi.com/api/v1/properties?id=xyz&blabla" & @CRLF & _
"dev.testapi.com/api/v1/properties?id=xyz" & @CRLF & _
"dev.testapi.com/api/v1/properties?id=xyz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")