// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w+)(?:(?:=|:)\w+)?$").unwrap();
let string = "https://dev.testapi.com/api/v1/properties?id:xyz&surname:kronenberg&active=true
https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&property_type:true
https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&active:true
https://dev.testapi.com/api/v1/properties?id=xyz&surname:kronenberg&user_id:true
dev.testapi.com/api/v1/properties?id=xyz&blabla
dev.testapi.com/api/v1/properties?id=xyz
dev.testapi.com/api/v1/properties?id=xyz";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}