#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)([\w\d]{1,})(\s{0,}-\s{0,})([\w\d]{1,})(\s{1,}|(\s{0,}-\s{0,}))([\w\d]{1,})"
Local $sString = "NORMAND SKIMMER DSB-WHSPLT-0212R" & @CRLF & _
"NORMAND SKIMMER DSB-WHSPLT 0212" & @CRLF & _
"NORMAND SKIMMER DSB-WHSTPLT 0212" & @CRLF & _
"NORMAND SKIMMER DSB - WHSPLT 0212" & @CRLF & _
"NORMAND SKIMMER DSB - WHSPLT - 0212" & @CRLF & _
"NORMAND SKIMMER 0212" & @CRLF & _
"NORMAND SKIMMER 0212R" & @CRLF & _
"NORMAND SKIMMER" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")