re = /([\w\d]{1,})(\s{0,}-\s{0,})([\w\d]{1,})(\s{1,}|(\s{0,}-\s{0,}))([\w\d]{1,})/i
str = 'NORMAND SKIMMER DSB-WHSPLT-0212R
NORMAND SKIMMER DSB-WHSPLT 0212
NORMAND SKIMMER DSB-WHSTPLT 0212
NORMAND SKIMMER DSB - WHSPLT 0212
NORMAND SKIMMER DSB - WHSPLT - 0212
NORMAND SKIMMER 0212
NORMAND SKIMMER 0212R
NORMAND SKIMMER
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end