// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)([\w\d]{1,})(\s{0,}-\s{0,})([\w\d]{1,})(\s{1,}|(\s{0,}-\s{0,}))([\w\d]{1,})").unwrap();
let string = "NORMAND SKIMMER DSB-WHSPLT-0212R
NORMAND SKIMMER DSB-WHSPLT 0212
NORMAND SKIMMER DSB-WHSTPLT 0212
NORMAND SKIMMER DSB - WHSPLT 0212
NORMAND SKIMMER DSB - WHSPLT - 0212
NORMAND SKIMMER 0212
NORMAND SKIMMER 0212R
NORMAND SKIMMER
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}