# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\B\w+| +//gmu;t' <<< "89 562
John Smith
Γιάννης Παπαδόπουλος
Jean-François Dupuis"