#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mu)\B\w+| +"
Local $sString = "89 562" & @CRLF & _
"John Smith" & @CRLF & _
"Γιάννης Παπαδόπουλος" & @CRLF & _
"Jean-François Dupuis"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)