using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B\w+| +";
string substitution = @"";
string input = @"89 562
John Smith
Γιάννης Παπαδόπουλος
Jean-François Dupuis";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}