package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\B\w+| +`)
var str = `89 562
John Smith
Γιάννης Παπαδόπουλος
Jean-François Dupuis`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}