package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<log_time>[0-9-]+ [:0-9,]+)\s+-\s+(?<severity>\w+)\s+-\s+(?<message>.*)$`)
var str = `2022-07-20 15:21:31,994 - INFO - Moving to Dashboard`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}