using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\((?:[^)(]+|\([^)(]*\))*\)";
string input = @"(A,B,C)(q,w)((A,q,B),(B,w,C)),(A),(C)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}