package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((?:[^)(]+|\([^)(]*\))*\)`)
var str = `(A,B,C)(q,w)((A,q,B),(B,w,C)),(A),(C)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}