$re = '/\((?:[^)(]+|\([^)(]*\))*\)/';
$str = '(A,B,C)(q,w)((A,q,B),(B,w,C)),(A),(C)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);