#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?im)^(?!$)(?:(Question|Problem:?|Example|[A-Z])[. ]?)?(\d+[. ]?)?(?=\s)"
Local $sString = "Q 12. This is question 1" & @CRLF & _
"Example 1 This is question 2 Q.1" & @CRLF & _
"Example This is question 3" & @CRLF & _
"EXAMPLE 2 This is question 4 2.3" & @CRLF & _
"Q.12. This is question 5" & @CRLF & _
"" & @CRLF & _
"5." & @CRLF & _
"Q 55." & @CRLF & _
"Q 555" & @CRLF & _
"Q.555." & @CRLF & _
"55555" & @CRLF & _
"Question 5555" & @CRLF & _
"Example" & @CRLF & _
"Problem 5555" & @CRLF & _
"Problem:" & @CRLF & _
"A5555." & @CRLF & _
"EXAMPLE" & @CRLF & _
"Example 5555555"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")