# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(\D*\d+\D+)\d+/$11/gm;t' <<< "messages_0_items_0_data_0
messages[0][items][0][data][0]"