$re = '/^(\D*\d+\D+)\d+/m';
$str = 'messages_0_items_0_data_0
messages[0][items][0][data][0]';
$subst = "$11";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;