import re
regex = re.compile(r"(\bVR\b)|(\bMA-DO\b)|(\bTUSSEN\b)|(\bTSS\b)|(\bOM\b)|(\bVOOR\b)|(\bTOT\b)|(\b\d{1,2}[HU.:*]\d{1,2}[U]\b)|(\b\d{1,2}[HU.:*]\d{1,2}\b)|(\b\d{1,2}[HU]\b)|(\bd{1,2}[HU]\b)")
test_str = ("LEVEREN ZONDER FOUT 25/08/2016 OM 8U REF. 090008865\n"
"LEVEREN ZONDER FOUT 24/08/2016 TSS 9U00 EN 11U00 REF:15453\n"
"LEVEREN TUSSEN 9.00-16.30 UUR\n"
"LEV TSS 9H-16H30/GEEN HEFTRUCK\n"
"LEV MA-DO 8H-16H30/VR 8H-12H30\n"
"LEVEREN ZONDER FOUT 12/09/2016 TUSSEN 09*00 EN 16*00 UUR\n"
"LEVEREN ZONDER FOUT 13/09/2016 OM 10*00U MET REF NR: 090009197\n"
"LEVEREN VOOR 15H00\n"
"LEV.MA-DO TOT 16H / VR TOT 14H TEST\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")