using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?!\$RR(\d,?)+).)*$";
string input = @"$RR11470,1,7,2,0,2
Боліваріанський альянс для народів Нашої Америки був створений у:
1) 2002 р.
2) 2003 р.
3) 2004 р.
4) 2005 р.
$RR11471,1,7,2,0,2
У межах АЛБА планується впровадження спільної валюти:
1) Болівар
2) Дінар
3) Ліра
4) Сукре
$RR11473,1,7,2,0,2
Яка з перелічених країн не є учасником АЛБА:
1) Венесуела
2) Колумбія
3) Куба
4) Нікарагуа
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}