#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[\u0591-\u05C7]"
Local $sString = "וַֽיַּעֲבֹר֙ אֶת־מִצְפֵּ֣ה גִלְעָ֔ד"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)