using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\u0591-\u05C7]";
string substitution = @"";
string input = @"וַֽיַּעֲבֹר֙ אֶת־מִצְפֵּ֣ה גִלְעָ֔ד";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}