import Foundation
let pattern = #"[\u0591-\u05C7]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"וַֽיַּעֲבֹר֙ אֶת־מִצְפֵּ֣ה גִלְעָ֔ד"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)