$re = '/\/.*\/.*(?<!.htm)$/m';
$str = '/blabla/test
/blabla/
/blabla/blabla.ht
/blabla/blabla.html
/bla/blabla.htm
blabla/
/blabla
blabla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);