#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:"([^"]*)"|'([^']*)'|(?:counter|attr|url)\(([^)]*)\))"
Local $sString = "counter(item)" " attr(data) "" counter(item1,decimal) url('test.jpeg') "hi" attr(xyz)" & @CRLF & _
"counter(name, style) " " invalid(data) url('test.jpeg') open-quote"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")