package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:"([^"]*)"|'([^']*)'|(?:counter|attr|url)\(([^)]*)\))`)
var str = `counter(item)" " attr(data) "" counter(item1,decimal) url('test.jpeg') "hi" attr(xyz)
counter(name, style) " " invalid(data) url('test.jpeg') open-quote`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}