$re = '/(?:"([^"]*)"|\'([^\']*)\'|(?:counter|attr|url)\(([^)]*)\))/m';
$str = 'counter(item)" " attr(data) "" counter(item1,decimal) url(\'test.jpeg\') "hi" attr(xyz)
counter(name, style) " " invalid(data) url(\'test.jpeg\') open-quote';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);