// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(?:"([^"]*)"|'([^']*)'|(?:counter|attr|url)\(([^)]*)\))"#).unwrap();
let string = "counter(item)\" \" attr(data) \"\" counter(item1,decimal) url('test.jpeg') \"hi\" attr(xyz)
counter(name, style) \" \" invalid(data) url('test.jpeg') open-quote";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}