$re = '/[^\[\]]*(?=(?:[^\]]*\[[^\[]*\])*[^\[\]]*$)/m';
$str = '8*2 Gripper ${FIRST_HALF?"Ret":"Ext"} [FA-050]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);