$re = '~^(?!zzz)(?=\S{2,5000}$).*(.{3}//.{0,100})(?!\w)~m';
$str = 'ssdfsdfsdfasdfasdfasdfdfd//yH5BAEkjfsdafdfsafasdfas
zzzsdf//yH5BAEkjfsdafdfsafasdfas
ssdfsdfsdfasdfasdfasdfdfd//yH5B';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);