package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(:[^:\n]+:[^:\n]+)*?:43:([^:]+)`)
var str = `:101:abc:12:43:43:101.4:4:bus
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}