using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""status\"":(?<status>[^\}])\"",\""requestId\"":";
string input = @"{""level"":""debug"",""message"":""handler result : {\""body\"":\""{\\\""numberOfProcessedRecords\\\"":1}\"",\""status\"":201}"",""requestId"":""ecd06f97-975b-5faf-81a0-3431fb4d1070""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}