// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\"status\":(?<status>[^\}])\",\"requestId\":"#).unwrap();
let string = "{\"level\":\"debug\",\"message\":\"handler result : {\\\"body\\\":\\\"{\\\\\\\"numberOfProcessedRecords\\\\\\\":1}\\\",\\\"status\\\":201}\",\"requestId\":\"ecd06f97-975b-5faf-81a0-3431fb4d1070\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}