re = /[\w\.-]*[a-zA-Z0-9_]@[\w\.-]*[a-zA-Z0-9]\.[a-zA-Z][a-zA-Z\.]*[a-zA-Z]/m
str = 'gabrielpg@unah.as'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end